Por favor, o Registro para crear entradas y debates.

Problemas en el modulo de Ali express

Buenos días

Estoy teniendo problemas con el modulo de ali. me deja muchos productos sin sicronizar y no me asigna las marcas de los productos. sabéis si es problema del modulo en sí o quizás tenga que desinstalarlo y volverlo a instalar

saludos

Dudo que sea problema del modulo.

Te aconsejo:

  1. Repasar que las marcas las tengas registradas de alta en Aliexpress.
  2. Revisar que las marcas estén mapeadas en el módulo.
  3. Ve a un producto que no te haya subido y dale a subir desde el producto. Te saldrán los errores de carga. Hay muchos motivos por los que un producto no puede cargar, pero casi nunca es por el modulo.  Campos obligatorios, configuraciones...

Gracias por responder Invitado

Muchos de esos productos han estado sincronizados durante días y por no se cual motivo dejan de sincronizarse, si le doy a actualizar desde el producto muchos de ellos lo hacen pero cuando le doy a sincronización masiva para actualizarlos todos pues no actualizan, con cron tampoco. no se a que se debe

@pedidosbacmarket-com revisa un par de temas que te aconsejo...

 

1- Salen las categorias dentro de los productos correctamente enlazadas? o aparecen en blanco o sin enlazar?

2- Podria ser que esten duplicados en Aliexpress... esto en ocasiones pasa y hay que modificar desde base de datos, pero lo primero es identificar la causa del problema

 

Espero tu respuesta y le damos un empujón a esto entro todos

buenos días

1- si están enlazadas

2- no están repetidos

Voy a intentarlo explicar mas gráficamente, con un ejemplo:

https://ibb.co/XjvRM0M

como se ve desde el día 18 de marzo no se ha actualizado

en prestashop desde la configuración de producto esta correcto:

https://ibb.co/Hd36CNr

Le doy a actualizar manualmente:

https://ibb.co/Ry0vqN9

et Voilà, producto actualizado

https://ibb.co/fMQ22Tf

el problema es hacerlo con todos, que paliza cuando se tendría que hacer solo

 

 

Revisa la configuración de la conexión y de los productos. Pon sincronización por Ajax, sincronización completa y al guardar. Es posible que por eso no sincronice todo. Tambien tener en cuenta que a veces hay cambios de categorías o piden nuevos atributos obligatorios.

Lo he tenido así como dices configurado pero con el mismo resultado, al final lo de AJAX lo quiete ya que me ralentizaba mucho prestashop y lo hago por cron. por otra parte no me pide nuevos atributos ya que al actualizar manual lo hace, esperare a la versión 2.0.5 haber si trae alguna mejora al respecto

Buenos días

al final me decantado por desinstalar el modulo ya que era imposible hacer nada con el, he tenido que anular algún pedido ya que al no estar sincronizados los productos alguno no tenia stock.

Pero la cosa no ha mejorado. me repite los productos cientos de veces, además cuando se suben los productos lo hacen sin publicarse, ósea que sube un producto pero desde prestashop si abres ese producto desde el modulo de aliexpress te sale como publicar. Ademas a la hora de mapear un producto no veo las categorías.

un desastre.

ali2

ali1

Creo que te están fallando las tablas de las bases de datos.

Para que se vean las categorías reinstala las tablas aliexpress_category_lang y aliexpress_sku_value_lang

En general creo que la mayoria de problemas vienen por fallos en la BD. Puede arreglarse desinstalando todo y borrando las Tablas de Aliexpress de la BD.

Hola invitado

ayer cuando desinstalé todo miré la base de datos y ya no había tablas. se habían borrado. Ósea que partíamos desde 0. Piensa que subí ayer unos 200 productos a ojo ya que no veía las categorías y esta mañana tenia 38000 productos, había repetido durante la noche todos los productos muchas veces. me duele el dedo de borrar tantos productos de 50 en 50, no se si alguien sabe una manera mas rápida de borrar los productos